Simulation error

5 posts / 0 new
Last post
Ahmadabu
Simulation error

Hi,
I tried importing a data file into SAM for simulation and I keep getting this error message. "missing temperature nan W/m2 at time [y:1999 m:1 d:1 h:0], exiting Simulation pvsamv1 failed." I used the software's solar resource file checker and it said there are no issues with the solar resource file, please what could be the problem?

Paul Gilman

Dear Ahmadabu,

Could you attach a copy of your weather file to your original post above (Edit the post to attach a file)? Otherwise, please email it to me at SAM Support.

Best regards,
Paul.

Ahmadabu

Hi Paul,
I have attached the weather file as directed.
Thanks

Paul Gilman

Your weather file uses the column label "TEMP" for temperature, which SAM does not recognize. The accepted labels are listed in the "Weather File Formats" topic in SAM's help system.

For example, you can change the label to "TDRY" -- note that SAM ignores case, so you could also use "tdry" or "Tdry".

Also, the photovoltaic performance models require a column of wind speed data, so you will need to add that to your file.

Best regards,
Paul.

Paul Gilman

Your weather file uses the column label "TEMP" for temperature, which SAM does not recognize. The accepted labels are listed in the "Weather File Formats" topic in SAM's help system.

For example, you can change the label to "TDRY" -- note that SAM ignores case in the labels, so you could also use "tdry" or "Tdry".

Also, the photovoltaic performance models require a column of wind speed data, so you will need to add that to your file.

Best regards,
Paul.

Theme by Danetsoft and Danang Probo Sayekti inspired by Maksimer