Make SSCAPIJNI.dylib file for Mac 10.12.6

1 post / 0 new
rae_d
Make SSCAPIJNI.dylib file for Mac 10.12.6

I'm trying to generate the SSCAPIJNI.dylib file for Java, Mac OS Darwin 10.12.6 with sam-sdk-2016-3-14-r3, but I get the following errors:

$ make -f TestSSCAPI.make
TestSSCAPI.make:96: *** Please check the settings for your system. Your system may not be supported. Please contact sam.support@nrel.gov. System: Darwin 10.12.6. Stop.

If I change the if condition on line 43 to look for 10.12, I get the errors below. Are there any options to get this to work with 10.12.6?

$ make -f TestSSCAPI.make
cp -f ../../sscapi.h ./sscapi.h
cp -f ../../examples/*.tm2 ./
cp -f ../../examples/*.csv ./
cp -f ../../osx64/ssc.dylib ./ssc.dylib
gcc -D_JNI_IMPLEMENTATION_ -I/System/Library/Frameworks/JavaVM.framework/Versions/Current/Headers -shared sscapi_wrap.c -o libSSCAPIJNI.jnilib ssc.dylib
sscapi_wrap.c:565:19: error: non-void function 'Java_SSC_SSCAPIJNI_ssc_1data_1get_1array' should return a value [-Wreturn-type]
if (!ssc_name) return ;
^
sscapi_wrap.c:604:19: error: non-void function 'Java_SSC_SSCAPIJNI_ssc_1data_1get_1matrix' should return a value [-Wreturn-type]
if (!ssc_name) return ;
^
2 errors generated.
make: *** [dll] Error 1

Theme by Danetsoft and Danang Probo Sayekti inspired by Maksimer