Help needed with tcsmolten_salt Version 159

5 posts / 0 new
Last post
ozsolarwind
Help needed with tcsmolten_salt Version 159

I'm attempting to use tcsmolten_salt with SDK Version 159 (2016.3.14) but am encountering a problem. I used the Inputs from SAM to create a set of SDK input variables but I must have something wrong. SAM gives a CF of around 0.42 but SDK execution gives -2. I've attached an LK Script and the input weather file. Any help appreciated. Thanks.

Angus

PS: Minor bug: It seem that even with is_dispatch=0, the is_dispatch=1 variables are required

Paul Gilman

Hi Angus,

The LK file generated by my copy of SAM 2016.3.14 looks very different from the LK script you attached above. There are a bunch of variables missing from your script, although it does run in my copy of SDKtool and generates the same -2 capacity factor that you see.

Could you try generating the LK script again from SAM (shift-F5)? Please double-check that you are using the latest version of SAM. To see the version number, click Help and then in the Help window, click About. SAM's SSC version number should match the one that is loaded in SDKtool.

Here is a link to the LK script I generated. If you have a way to do a text compare, you'll quickly see the difference between the two files.

Best regards,
Paul.

 

ozsolarwind

Paul

Thanks once again. Your script produces useful results. The one I created was minimalist with just those variables I felt I needed from the REQUIRE column - values of ['*', 'tes_type=1', 'pc_config=0', 'is_dispatch=1']. I'll now compare and find my problem.

Kind regards

Angus

ozsolarwind

Paul

And I'll try and remember Shift-F5 :-)

ozsolarwind

Paul

Sheepishly, I had a problem with 'Turbine output fraction' set at 0 rather than 1.
var ('f_turb_tou_periods', [1, 1, 1, 1, 1, 1, 1, 1, 1]); works better than var ('f_turb_tou_periods', [0, 0, 0, 0, 0, 0, 0, 0, 0]);

Kind regards

Angus

Theme by Danetsoft and Danang Probo Sayekti inspired by Maksimer